Vito Owners Club

Mercedes vito, viano owners club
 
HomeHome  PortalPortal  FAQFAQ  SearchSearch  RegisterRegister  MemberlistMemberlist  UsergroupsUsergroups  Log in  

Share | 
 

 Temp gauge in red even when engine is cold

View previous topic View next topic Go down 
AuthorMessage
Gerbutt



Posts : 1
Join date : 2010-01-03

PostSubject: Temp gauge in red even when engine is cold   Sun Jan 03, 2010 7:31 am

Hiya, I've a 2000 reg 108cdi with a problem. When I turn it on from cold the temp gauge goes straight to the red, the fan cuts in and when driven it has loss of power? Thermostats opening ok. Where is the temp sensor located please? Thanks
Back to top Go down
View user profile
VitoSpares



Posts : 6
Join date : 2010-04-22

PostSubject: Re: Temp gauge in red even when engine is cold   Thu Apr 22, 2010 2:32 pm

Hey,

The temp sensor is located on the thermostat housing, Its held in by a clip, but you'll break it trying to take it out so the best bet is to get the whole casing from MB!

Could be the Relays that are situated above the radiator!??

Mark
Back to top Go down
View user profile http://www.vitospares.com
 
Temp gauge in red even when engine is cold
View previous topic View next topic Back to top 
Page 1 of 1
 Similar topics
-
» temp gauge wiring
» Water Temp Gauge
» Transmission temp gauge
» Temp light on when engine is cold??
» TEMP GAUGE FOR VW T4

Permissions in this forum:You cannot reply to topics in this forum
Vito Owners Club :: General :: General Chat-
Jump to: